Jump to content
YoshinJaa

Repopulate Halo 2 Vista

Recommended Posts

So (as many on this forum know) I've been able to enjoy this game whenever I wanted.. Up until today! For some reason I can't join games any more (I'm briefly in the pre-game lobby, then immediately booted).

 

Has this happened to anyone before? I know of people experiencing the issue upon first installing the game, but never after having already played it for a while.

Share this post


Link to post

OP updated with the client patch program installation guide and links. You will need to download .NET Framework 4.5.2 and Visual C++ Update 4 x86 version FIRST before attempting to use H2Launcher!

If you have the game installed and running already, once you have installed both programs, click Register in H2 Shark. You do not need to activate the game or shark, especially if the game was already activated by a product key or alternate guide before. Register your H2PC account by signing into live and setting a password, then click Register and you will see Registration Successful! The game will then close and prompt you to login to your H2PC account. That's it!

Share this post


Link to post

So (as many on this forum know) I've been able to enjoy this game whenever I wanted.. Up until today! For some reason I can't join games any more (I'm briefly in the pre-game lobby, then immediately booted).

 

Has this happened to anyone before? I know of people experiencing the issue upon first installing the game, but never after having already played it for a while.

Not sure if that was happening earlier. The server has been restarted and you will now need the client program to connect to the MLG lobbies. Try again and see if you are having the same issue.

Share this post


Link to post

I followed the directions and installed everything correctly, but my game doesn't have audio at all and I can only seem to join games like 25% of the time. Not sure if anyone else is having this problem or knows how to fix it.

Share this post


Link to post

I followed the directions and installed everything correctly, but my game doesn't have audio at all and I can only seem to join games like 25% of the time. Not sure if anyone else is having this problem or knows how to fix it.

Audio issue is happening for me as well.

  • Upvote (+1) 1

Share this post


Link to post

I've been having some framerate issues ever since I started using the H2 Shark thing, the game stutters to the point where it's almost unplayable. Didn't have any issues before using it.

Share this post


Link to post

Audio issue is happening for me as well.

I followed the directions and installed everything correctly, but my game doesn't have audio at all and I can only seem to join games like 25% of the time. Not sure if anyone else is having this problem or knows how to fix it.

The audio issue is affecting a very small group at the moment only you guys and one other person has reported, we are looking into it though.

Share this post


Link to post

Yeah the same thing is happening to me right now...I've been playing the game with no issues and today I get on and I try to join a lobby and I immediately get booted out...Any fix for this issue?

Share this post


Link to post

Yeah the same thing is happening to me right now...I've been playing the game with no issues and today I get on and I try to join a lobby and I immediately get booted out...Any fix for this issue?

Did you download the patch in the OP? If so, are you able to join other servers?

 

Audio related issue here is a work around:

Go to C:\Program Files (x86)\Microsoft Games\Halo 2 and switch the names of _dsound.dll and dsound.dll (so _dsound should be named dsound and dsound should be renamed _dsound). If your game crashes after renaming, let me know.

Share this post


Link to post

Unfortunately the people without the patch that are joining in game and getting booted automatically is causing constant lag in the room every time a new person joins ;(

Share this post


Link to post

Unfortunately the people without the patch that are joining in game and getting booted automatically is causing constant lag in the room every time a new person joins ;(

yeah, try your best to inform them, I am reaching out as fast as possible 

Share this post


Link to post

Now when I run the game it starts fine but after 10-15 second I start seeing a heavy decrease in FPS until it no longer responds. I've reinstalled the game and it hasn't made a difference. I've been able to get into a multiplayer game quickly but it still went unresponsive like usual. Know of any solutions to this problem?

 

Windows 7 64bit

 

I've figured out that Games for Windows Live is causing my problems, I uninstalled it and installed version 3.5.88.0 (older version). Now the game runs perfectly, however if I update it (GFWL) it goes right back to freezing. I'm not sure where to go from here.

Share this post


Link to post

So I've been at it for 4 hours trying to play using the new Shark Client and this is just downright painful.... I posted some comments in the youtube video but let me be thorough here, it may help you debug this guy (in the case something is wrong with it), it's entirely possible my PC is having issues with it.

 

WIndows 8.1, 64 bit, NVIDIA GeForce GTX 860M, Driver 9.18.13.4052. (I have an ASUS Laptop) - can get more specs if needed.

 

Followed your Youtube video to the tee and besides the account key not working (didn't matter since I had one of my own), everything appeared to work. Up until this point I've had to use a modified halo2.exe with -novsync at the end of a target for a shortcut to run the game smoothly without issues with the correct movement speed in-game. Upon using this new shark client, I encountered so many different graphics glitches. The startup screen with the blue images in the background was going crazy fast and twiching image to image in fast motion. The whole game seemed to be trying to run at an incredibly high fps. After trial and error for hours upon hours, I finally tried the FPS Limiter you mentioned in a different post and the game works beautifully if I completely ignore Shark Client and just run the batch exe from FPS Limiter. Game runs smoothly, perfect movement speed, omg yay. The tricky part is when I need to play the game with Shark Client and yet still utilize this FPS Limiter....I have tried so many different combinations of booting up the game with Shark Client and then alt-tabbing and activating the FPS Limiter batch file and then going back to the game and nothing works. If I boot from the Shark Client first, the game starts up at hyper fps graphics glitches and is unplayable. If I then alt-tab out and activate the batch file to limit the fps, it doesn't work since the game is already booted up and in hyper mode. If I boot up the game via the FPS limiter, it's gorgeously smooth and functional but then I don't have that Ranked mode functionality of shark client since the exe needs to boot the game to function (as far as I can tell). Not sure how to solve this problem. The saddest part of all of this is that now my Shark Client won't even pull up the GUI for it. I open it and nothing happens, no popup, no notifications that it is even running. Deleting the exe and "reinstalling" it doesn't do much either. I'm going to try removing the .net framework and such and then readding it along with the exe, I'm guessing that is somehow the issue. From there, not sure where to go to get this functioning. All I can think of doing is logging into Shark Client and somehow getting it to activate the batch file for the game rather than the standard halo2.exe (may rename?) LOL Idk but any help would be appreciated.. If I can get this functioning and I'm allowed to grind till MCC, you will definitely see a donation from me in appreciation, this is awesome work, I just have a pos laptop haha.

Share this post


Link to post

So I've been at it for 4 hours trying to play using the new Shark Client and this is just downright painful.... I posted some comments in the youtube video but let me be thorough here, it may help you debug this guy (in the case something is wrong with it), it's entirely possible my PC is having issues with it.

 

WIndows 8.1, 64 bit, NVIDIA GeForce GTX 860M, Driver 9.18.13.4052. (I have an ASUS Laptop) - can get more specs if needed.

 

Followed your Youtube video to the tee and besides the account key not working (didn't matter since I had one of my own), everything appeared to work. Up until this point I've had to use a modified halo2.exe with -novsync at the end of a target for a shortcut to run the game smoothly without issues with the correct movement speed in-game. Upon using this new shark client, I encountered so many different graphics glitches. The startup screen with the blue images in the background was going crazy fast and twiching image to image in fast motion. The whole game seemed to be trying to run at an incredibly high fps. After trial and error for hours upon hours, I finally tried the FPS Limiter you mentioned in a different post and the game works beautifully if I completely ignore Shark Client and just run the batch exe from FPS Limiter. Game runs smoothly, perfect movement speed, omg yay. The tricky part is when I need to play the game with Shark Client and yet still utilize this FPS Limiter....I have tried so many different combinations of booting up the game with Shark Client and then alt-tabbing and activating the FPS Limiter batch file and then going back to the game and nothing works. If I boot from the Shark Client first, the game starts up at hyper fps graphics glitches and is unplayable. If I then alt-tab out and activate the batch file to limit the fps, it doesn't work since the game is already booted up and in hyper mode. If I boot up the game via the FPS limiter, it's gorgeously smooth and functional but then I don't have that Ranked mode functionality of shark client since the exe needs to boot the game to function (as far as I can tell). Not sure how to solve this problem. The saddest part of all of this is that now my Shark Client won't even pull up the GUI for it. I open it and nothing happens, no popup, no notifications that it is even running. Deleting the exe and "reinstalling" it doesn't do much either. I'm going to try removing the .net framework and such and then readding it along with the exe, I'm guessing that is somehow the issue. From there, not sure where to go to get this functioning. All I can think of doing is logging into Shark Client and somehow getting it to activate the batch file for the game rather than the standard halo2.exe (may rename?) LOL Idk but any help would be appreciated.. If I can get this functioning and I'm allowed to grind till MCC, you will definitely see a donation from me in appreciation, this is awesome work, I just have a pos laptop haha.

I'll take a look at it, not sure about the FPS issues though, Shark is still in beta so there are possibilities of issues arising. 

Share this post


Link to post

Just a heads up but I've been unable to get Shark to function again. Removing and re-adding Visual C++ and .net Framework has had no effect.

Share this post


Link to post

Been running more games using the new launcher and I think I have a better understanding of my framerate issues while using it. My games always start out at 60fps when I first boot up H2. After I play for maybe 10-15 minutes, my framerate slowly begins to drop by like 1-2 fps per minute. If I play for long enough, my framerate will be down in the 20s and I'll need to reboot H2 to make it go back to 60fps. I'm not sure how the new launcher factors in to all this.

Share this post


Link to post

Did you download the patch in the OP? If so, are you able to join other servers?

 

Audio related issue here is a work around:

Go to C:\Program Files (x86)\Microsoft Games\Halo 2 and switch the names of _dsound.dll and dsound.dll (so _dsound should be named dsound and dsound should be renamed _dsound). If your game crashes after renaming, let me know.

 

This did fix my no-sound issues, but my game is crashing shortly after joining games. Sometimes it crashes to desktop and other times I get booted to the main menu.

Share this post


Link to post

Been running more games using the new launcher and I think I have a better understanding of my framerate issues while using it. My games always start out at 60fps when I first boot up H2. After I play for maybe 10-15 minutes, my framerate slowly begins to drop by like 1-2 fps per minute. If I play for long enough, my framerate will be down in the 20s and I'll need to reboot H2 to make it go back to 60fps. I'm not sure how the new launcher factors in to all this.

I had the exact same issue which I resolved with FPS Limiter but unfortunately I can't find a way to make that work with Shark Client.

Share this post


Link to post

Hi guys,

is there any other way to activate game because  ,phone option is not working for me.

I didn't need activation before but now with H2Launcher i cant join servers anymore.

I'm getting some eror message.

Pls help!

Share this post


Link to post

I'm  getting "Online Multiplayer Blocked" message. What now?

 

Edit: Restart fixed it. Everything seems to be fine, except for getting my ass handed to me every time  :trash:

Share this post


Link to post

Anyone else having trouble opening the H2Launcher file? I ran the .NET Framework and the Visual C++ Redistributable Update 4 and installed those successfully. When I try to run H2Launcher.exe nothing happens. The icon shows up on my task bar, but when I hover over it it disappears.

Share this post


Link to post

Anyone else having trouble opening the H2Launcher file? I ran the .NET Framework and the Visual C++ Redistributable Update 4 and installed those successfully. When I try to run H2Launcher.exe nothing happens. The icon shows up on my task bar, but when I hover over it it disappears.

Same exact problem I encountered most recently.

Share this post


Link to post

First I'm going to assume you either A, have the torrent or B had the game installed and then moved the installation folder?

 

Shark scans the registry for the halo 2 installation folder, if it cannot find it, it won't open.

 

Either reinstall the game. or manually navigate to this place in the registry and specify where your game install is.

32 bit: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Halo 2\1.0\

64 bit: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Microsoft Games\Halo 2\1.0\

 

Create a string value and name it GameInstallDir, then right click modify and put in your installation location. Without the halo2.exe

 

example C:\Program Files (x86)\Microsoft Games\Halo 2\

  • Upvote (+1) 2

Share this post


Link to post

YOU'RE THE MAN! Gonna give this a shot, I did move the destination a while back. I'll let you know what happens.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Privacy Policy.