Jump to content
YoshinJaa

Repopulate Halo 2 Vista

Recommended Posts

Plugged my xbox 360 controller in and let it install drivers and all that. Played a couple games and it was fine for hte most part except for every minute or so my aim would go bezerk. I'd be shooting someone and all of a sudden I'd be looking straight up (or down/right/left.). Is this just something that happens on H2V because of lag or is there something wrong with my controller?

 

edit: Unplugged my mouse and that fixed it.

 

Unplugging my mouse didn't fix it.. started to occur again a few games after. My controller is now randomly firing, moving the aimer around, B button is doing what A button does, RT is hitting start sometimes.. then it works fine for a minute and messes up again. Controller works perfect on xbox 360.

 

Any suggestions? I turned v-sync on as per a suggestion on another board, but that didnt help.

Share this post


Link to post

Unplugging my mouse didn't fix it.. started to occur again a few games after. My controller is now randomly firing, moving the aimer around, B button is doing what A button does, RT is hitting start sometimes.. then it works fine for a minute and messes up again. Controller works perfect on xbox 360.

 

Any suggestions? I turned v-sync on as per a suggestion on another board, but that didnt help.

Are you using a 3rd party controller? Make sure to plug in before starting the game, that is a known problem that causes the controller to be read incorrectly. 

Share this post


Link to post

Are you using a 3rd party controller? Make sure to plug in before starting the game, that is a known problem that causes the controller to be read incorrectly. 

 

Xbox controller. Think my issue was not plugging in before starting the game. It's working now.

Share this post


Link to post

Hey YoshinJaa thanks for sticking with me I appreciate it!! But I still can't get it to work:(  I downloaded the game perfectly on my PC and followed your steps and it worked fine but my PC is 10 years old so the game didn't work to smooth.  I then downloaded bootcamp on my Macbook pro and got Windows 7 working and Halo 2 installed.  The only problem is the error code 0x8007065B, I deleted the content folder like the other person said and still got the same error:(  I just want to play some Halo 2 before Halo MCC comes out so I can freshen up my game.  I clicked on network and this is what it showed....

 

2yn135i.jpg

 

Is this normal?? I don't know what any of this means, maybe it might be why I keep getting the error?? Thanks for helping man 

Share this post


Link to post

Hey YoshinJaa thanks for sticking with me I appreciate it!! But I still can't get it to work:(  I downloaded the game perfectly on my PC and followed your steps and it worked fine but my PC is 10 years old so the game didn't work to smooth.  I then downloaded bootcamp on my Macbook pro and got Windows 7 working and Halo 2 installed.  The only problem is the error code 0x8007065B, I deleted the content folder like the other person said and still got the same error:(  I just want to play some Halo 2 before Halo MCC comes out so I can freshen up my game.  I clicked on network and this is what it showed....

 

Is this normal?? I don't know what any of this means, maybe it might be why I keep getting the error?? Thanks for helping man 

Your profile download appears to be corrupted. Try either downloading another profile, use another internet connection just to download your profile (like a phone hotspot), disable your Anti-Virus and/or Firewall. 

 

Also, try this http://support.microsoft.com/kb/299357 and download the FixIt version based off of your Windows version. 

Share this post


Link to post

Alright, I'm looking into these error codes more precisely.  Please could you all take a screenshot of the error code in game, with the reason it belongs to.  Thank you.  I will try to reproduce these error codes and fix them on my end.

  • Upvote (+1) 1

Share this post


Link to post

Did you set it as application specific? http://gyazo.com/ab3086e85b4da81f777987eca35023d3

Make sure Wait for Vertical Refresh = Always On and you can also enable Triple Buffering. If that does not work, look at the 2nd post in FAQs and try RadeonPro.

 

Tried RadeonPro with no luck, it just seems to take a little longer until it freezes. Sound continues to play, just not video.

Share this post


Link to post

Buckness do u have windows 7? i have a feeling it has issues with windows 7. and i know they have that windows 7 fix thing and i have ran it but it still doesnt fix it.

no i have windows 8

Share this post


Link to post

@@YoshinJaa did u find a fix for the c++ issue?

The only thing I know of as well as what @@supersniper told me was that you would need to reinstall your VC++ redistributable files as that is the likely cause of the error. You already did that right?

Share this post


Link to post

@@Reverate

In response to this video.

I have seen this error before with a gamer named Nitride. We got his game up and running through these methods.

 

Steps and Methods we used were, checking MTU settings in the computer registry and router to make sure they are set at default, reset the TCP/IP protocol for the computer, and dragging the corresponding xlive.dll and security catalogue file in the root folder.

 

First before you do anything, update the game manually, and install the latest version of LIVE.

 

Method 1

Visit here and navigate to the registry key and see what the value is. This page lists default values for internet connection speeds. Make sure they are set correctly in the registry and your router.

If the settings were default then move to method 2, if they were not restart and try launching the game.

 

Method 2

If method one did not work, go here and choose which ever way you want to do it. Fix it is the automatic way however there is a manual way too. Restart the computer then launch halo 2 and see if it worked. If it did not work go to method 3.

 

Method 3

Dragging the xlive.dll and xlive.dll.cat files into the halo 2 root folder. This will force halo 2 to launch the xlive.dll because the game checks for dlls associated in the root folder before it checks other locations. You need to get the .dll and cat file from someone who has the game working so contact me back if the above 2 methods didn't work and I'll send you the corresponding files you need. Hopefully this will fix it because these are the 3 methods we did with Nitride and his works.

  • Upvote (+1) 1

Share this post


Link to post

@@supersniper thanks for that! Ok - I didn't have a registry value for my MTU so I created a DWord one as it said, and I put in the value 1492, although to be perfectly honest I have no idea which number I'm supposed to go for! I'm not plugged in through an Ethernet Cable so it shouldn't be 1500, so I ended up trying the IEEE 802.3/802.2 one. I'll just go through all of the numbers now and see if any work but if not, should it be set to a specific setting before I run the "Fix It" program in method 2?

Share this post


Link to post

@@Reverate Um the fix it one just goes in and resets it to default settings. Try the method one first, if nothing do 2. And still nothing then I'll upload my xlive files and you drag them to the installation folder.

Share this post


Link to post

@@supersniper I've now tried every single different MTU setting and also tried method 2 and it's still not working. Although after running the Fix IT program my custom value for the MTU does still seem to be there, anyway. I guess my last hope is to try the working xlive files. If you could upload them it would be much appreciated! Also, should I delete the xlive files from my sysWOW64 folder when I copy your versions into the Halo 2 folder? Thanks again!

 

oh and here's a screenshot of my current "Parameters" folder in the registry in-case you happen to see anything I've done wrong

http://i.gyazo.com/994886b9d7d172af1cc0cbf1ce40d0e0.png

Share this post


Link to post

No do not delete them from you Halo 2 folder.

 

http://www.halo2vista.com/downloads/

 

Download the correct version of xlive you need. and drag them to your installation folder.

 

And for the MTU settings

 

They need to be set according to what internet speed you have in the registry and in your router.

 

•576 - Dial-up Connections

•1492 - PPPoE Broadband Connections

•1500 - Ethernet, DSL and Cable Broadband Connections

Share this post


Link to post

The only thing I know of as well as what @@supersniper told me was that you would need to reinstall your VC++ redistributable files as that is the likely cause of the error. You already did that right?

ummmm lets say i didnt how do i haha

Share this post


Link to post

I'm finally online guys, for some reason I have to change my IP address to dynamic from static everytime I want to play.

 

Anyway, some new issues:

 

Halo 2 is running in slow motion, FRAPS is counting ~420 fps and i'm using a Intel 2500k, GTX 660ti, and 8Gb of RAM

 

I tried a fix which was turning vertical sync on in nvidia options which locked the fps to 60fps and the game runs stable again and not in slow motion, however I can't aim well with vertical sync turned on, dont ask why, i have to keep it off in all shooters on pc. 

 

So i'm looking for a solution to this if anyone knows of one, i'ver already had a scour of the internet but can't find much help.

Share this post


Link to post

is it me or does the xbox one controller feel a bit off in terms of input? I think the deadzones may be off....360 controller feels normal tho

Share this post


Link to post

is it me or does the xbox one controller feel a bit off in terms of input? I think the deadzones may be off....360 controller feels normal tho

I use a Xbox One controller and I haven't had any off input, the 360 controller feels the same way on my end. One thing to note as that the Xbox One drivers are in beta, so that may have something to do with it. Also, check and see if you have any Windows Updates recently, I believe there was a driver update through those channels. 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Privacy Policy.